ZDaemon Forum Index ZDaemon
Client/Server DOOM
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Zdaemon 1.08 Bugs
Goto page 1, 2, 3 ... 19, 20, 21  Next
 
Post new topic   This topic is locked: you cannot edit posts or make replies.    ZDaemon Forum Index -> ZDaemon Development
View previous topic :: View next topic  
Author Message
climhazzard
Spamming!


Joined: 25 Oct 2004
Location: Michigan

PostPosted: Sat Dec 24, 2005 3:08 am    Post subject: Zdaemon 1.08 Bugs Reply with quote

Bug #1: I run ZDaemon in windowed mode, when I minimize ZDaemon.exe, then maximize it ZDaemon lags up then opens eventually but once it loads up I get about 20 of these messages
Code:
Input packet Queue Full

I also get one or two of these once I maximize
Code:
Client SZ_Getspace: OVERFLOW


Although I occasionaly got the getspace error in ZDaemon 1.07, it never ate up so much of my resources that it lagged my computer.

I'm guessing this bug has something to do with the 'improved' netcode

Bug #2: I've seen floating flags around in the CTF servers quite a bit today, when you press \ to view the players, the guy with the flag appears as a spectator.

> Keep all ZDaemon 1.08 bugs in this thread <
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address MSN Messenger
[n00b]Adereth
Spamming!


Joined: 16 Jul 2005
Location: Oh god, what year is this?!

PostPosted: Sat Dec 24, 2005 3:46 am    Post subject: Reply with quote

Bug #3: Latency in the appearance of formerly inactive monsters; players sometimes seem to take a few frames to appear once they leap out from behind a corner. *generic n00bish trash-talk about network code changes*
Back to top
View user's profile Send private message Visit poster's website AIM Address
ufon
Spamming!


Joined: 25 Aug 2003
Location: Czech republic

PostPosted: Sat Dec 24, 2005 10:17 am    Post subject: Reply with quote

there is something wrong with the sound, sorry if this has been brought up before somewhere else....plasma and rockets are much more louder than the rest of the weapons, didnt have this problem in 1.07.....i have onboard sound, ac97 or whatever chip that is
Back to top
View user's profile Send private message
Exl
I hate penis like vegetables.


Joined: 13 Feb 2004
Location: North of the fries, east of the wieners, west of the tea

PostPosted: Sat Dec 24, 2005 10:38 am    Post subject: Reply with quote

The sound stuff is known about and Kilgore said he'd be looking into it.
Back to top
View user's profile Send private message Visit poster's website
BAZOOKA
Spamming!


Joined: 10 Feb 2004

PostPosted: Sat Dec 24, 2005 3:49 pm    Post subject: Reply with quote

sound pitched doesnt work in this version for me. It was running ok in previous versions
Back to top
View user's profile Send private message
Stealth
Gone with the wind


Joined: 09 Nov 2004

PostPosted: Sat Dec 24, 2005 5:42 pm    Post subject: Reply with quote

BAZOOKA wrote:
sound pitched doesnt work in this version for me. It was running ok in previous versions


I agree with BAZOOKA on this part, there is something up with the random pitch variations here. Probably to do with new library.

Another bug, probably due to map fault which allowed me to shoot through walls in tctf. Only worked with the plasma gun, though. The cells couldn't be seen (acted as if they hit the wall) and other weapons didn't work.
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
BAZOOKA
Spamming!


Joined: 10 Feb 2004

PostPosted: Sat Dec 24, 2005 6:14 pm    Post subject: Reply with quote

Today i was playing Lap brit11 and i had good ping but noticed a big lag. i couldnt hit my opponents like old version of zdaemon. Do you notice the same thing?
Back to top
View user's profile Send private message
[n00b]Adereth
Spamming!


Joined: 16 Jul 2005
Location: Oh god, what year is this?!

PostPosted: Sat Dec 24, 2005 8:32 pm    Post subject: Reply with quote

Sound code troubles: No way to adjust volume of OGG music (other waveform music types too?)
Back to top
View user's profile Send private message Visit poster's website AIM Address
climhazzard
Spamming!


Joined: 25 Oct 2004
Location: Michigan

PostPosted: Sat Dec 24, 2005 10:06 pm    Post subject: Reply with quote

Once you exit from ZDaemon, the midi plays for about 5 seconds after ZDaemon is closed.
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address MSN Messenger
[LoD]Polie[IR]
has entered the game!


Joined: 18 May 2005

PostPosted: Sat Dec 24, 2005 10:23 pm    Post subject: Reply with quote

climhazzard wrote:
Once you exit from ZDaemon, the midi plays for about 5 seconds after ZDaemon is closed.


This is due to computer lag, not ZDaemon.
Back to top
View user's profile Send private message
Slasher
Spamming!


Joined: 04 Oct 2004

PostPosted: Sun Dec 25, 2005 12:08 am    Post subject: Reply with quote

BAZOOKA wrote:
Today i was playing Lap brit11 and i had good ping but noticed a big lag. i couldnt hit my opponents like old version of zdaemon. Do you notice the same thing?


yeah.. it usually happens with a ping of around 50-70.

If I recall correctly unlagged is applied only when your ping is higher than 40ms ?
Whats the command to disable it? I wanna do some tests =P.
Back to top
View user's profile Send private message
climhazzard
Spamming!


Joined: 25 Oct 2004
Location: Michigan

PostPosted: Sun Dec 25, 2005 2:06 am    Post subject: Reply with quote

My computer is more than powerful enough to run ZDaemon though. It doesn't make any sense that my comptuer would lag while playing or exiting it.
[LoD]Polie[IR] wrote:
climhazzard wrote:
Once you exit from ZDaemon, the midi plays for about 5 seconds after ZDaemon is closed.


This is due to computer lag, not ZDaemon.
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address MSN Messenger
[LoD]Polie[IR]
has entered the game!


Joined: 18 May 2005

PostPosted: Sun Dec 25, 2005 10:33 am    Post subject: Reply with quote

climhazzard wrote:
My computer is more than powerful enough to run ZDaemon though. It doesn't make any sense that my comptuer would lag while playing or exiting it.
[LoD]Polie[IR] wrote:
climhazzard wrote:
Once you exit from ZDaemon, the midi plays for about 5 seconds after ZDaemon is closed.


This is due to computer lag, not ZDaemon.


Maybe so, but that still doesn't stop the fact it is because of computer lag. It isn't a bug in ZDaemon Razz
Back to top
View user's profile Send private message
The Ultimate DooMer
Spamming!


Joined: 30 Aug 2004

PostPosted: Sun Dec 25, 2005 12:12 pm    Post subject: Reply with quote

Replacement dsoof sounds are still overridden by the default one.
Back to top
View user's profile Send private message Send e-mail
spacepirate
AssPants


Joined: 25 Jan 2005
Location: que pasa

PostPosted: Sun Dec 25, 2005 1:07 pm    Post subject: Reply with quote

The stupid invisible revenant ball in coop is still annoying.. Confused

Also I was playing Plutonia and I got this:

Code:
zd_killmobj: cannont find actor xxx
Back to top
View user's profile Send private message
TimeOfDeath
Spamming!


Joined: 03 Nov 2004

PostPosted: Sun Dec 25, 2005 4:24 pm    Post subject: Reply with quote

inf_spacepirate wrote:
The stupid invisible revenant ball in coop is still annoying.. Confused

Also I was playing Plutonia and I got this:

Code:
zd_killmobj: cannont find actor xxx

I started getting that message in either 1.07 or 1.07.01. And yes, some coop fixes in the future sure would be dandy Very Happy
Back to top
View user's profile Send private message Visit poster's website
Danni
Spamming!


Joined: 25 Oct 2003

PostPosted: Sun Dec 25, 2005 5:38 pm    Post subject: Reply with quote

Tell me the maps you have issues with i will look into it.
Back to top
View user's profile Send private message
julz_d
Spamming!


Joined: 30 Sep 2004

PostPosted: Mon Dec 26, 2005 11:32 am    Post subject: Reply with quote

Not too important, but keep on getting the "OOOF!" sound when walking around in spectator mode (Offline mode only as of yet). Mostly happens when I walk into walls or move to diff heights in the map.

Note: This bug was first noticed during the creation of MAP02 of my COOP project.
Back to top
View user's profile Send private message Send e-mail
BAZOOKA
Spamming!


Joined: 10 Feb 2004

PostPosted: Mon Dec 26, 2005 3:59 pm    Post subject: Reply with quote

Another thing. Since version 1.7 everytime i see a demo i get the message each 8 seconds "sz_getspace : overflow" and still happening in this version.
Back to top
View user's profile Send private message
[n00b]Adereth
Spamming!


Joined: 16 Jul 2005
Location: Oh god, what year is this?!

PostPosted: Mon Dec 26, 2005 4:57 pm    Post subject: Reply with quote

Wild guess: http://www.planethalflife.com/commands/faq.shtml#12

Quote:
12. What does SZ_Getspace mean? I get asked this question a lot, mainly because it can be an common sight on your server. Basically what it means, though, is that a client is too slow in receiving the data packets that the server is sending to it.


In short, probably lag or low-bandwidth troubles.
Back to top
View user's profile Send private message Visit poster's website AIM Address
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    ZDaemon Forum Index -> ZDaemon Development All times are GMT + 1 Hour
Goto page 1, 2, 3 ... 19, 20, 21  Next
Page 1 of 21

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group