ZDaemon Forum Index ZDaemon
Client/Server DOOM
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

ZDaemon Mac OS X build
Goto page Previous  1, 2, 3, 4, 5
 
Post new topic   Reply to topic    ZDaemon Forum Index -> ZDaemon Help & Chatter
View previous topic :: View next topic  
Author Message
Bardur
has entered the game!


Joined: 29 Dec 2013

PostPosted: Wed Apr 11, 2018 3:37 pm    Post subject: Reply with quote

Is SDL-lookup fixed in 1.10.03. ?
Back to top
View user's profile Send private message
Lyfe
Puts the 'Z' in ZDaemon


Joined: 29 May 2002

PostPosted: Wed Apr 11, 2018 4:53 pm    Post subject: Reply with quote

Was it broken in 1.10, 1.10.01, or 1.10.02?
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Bardur
has entered the game!


Joined: 29 Dec 2013

PostPosted: Wed Apr 11, 2018 5:20 pm    Post subject: Reply with quote

My friend had problems with 1.10.02.

Quote:

[22:46] <tykje_> Process: ZDaemon [2029]
[22:46] <tykje_> Path: /Applications/ZDaemon/ZDaemon.app/Contents/MacOS/ZDaemon
[22:46] <tykje_> Identifier: org.zdaemon.ZDaemon
[22:46] <tykje_> Version: ZDaemon version 1.08.08 (1.0)
[22:46] <tykje_> Code Type: X86 (Native)
[22:46] <tykje_> Parent Process: ??? [1]
[22:46] <tykje_> Responsible: ZDaemon [2029]
[22:46] <tykje_> User ID: 501
[22:46] <tykje_> Date/Time: 2018-04-10 22:45:47.538 +0200
[22:46] <tykje_> OS Version: Mac OS X 10.13.4 (17E199)
[22:46] <tykje_> Report Version: 12
[22:46] <tykje_> Anonymous UUID: 5999F6B7-7461-C817-0A14-98ABAACF45FF
[22:46] <tykje_> Time Awake Since Boot: 1000 seconds
[22:46] <tykje_> System Integrity Protection: enabled
[22:46] <tykje_> Crashed Thread: 0
[22:47] <tykje_> Exception Type: EXC_CRASH (SIGABRT)
[22:47] <tykje_> Exception Codes: 0x0000000000000000, 0x0000000000000000
[22:47] <tykje_> Exception Note: EXC_CORPSE_NOTIFY
[22:47] <tykje_> Termination Reason: DYLD, [0x1] Library missing
[22:47] <tykje_> Application Specific Information:
[22:47] <tykje_> dyld: launch, loading dependent libraries
[22:47] <tykje_> Dyld Error Message:
[22:47] <tykje_> Library not loaded: @rpath/SDL2.framework/Versions/A/SDL2
[22:47] <tykje_> Referenced from: /Applications/ZDaemon/ZDaemon.app/Contents/MacOS/ZDaemon
[22:47] <tykje_> Reason: image not found
[22:47] <tykje_> Binary Images:
[22:47] <tykje_> 0xf0000 - 0x2d7ff3 +org.zdaemon.ZDaemon (ZDaemon version 1.08.08 - 1.0) <8AF4C096-D512-3946-B694-69B04B2917F8> /Applications/ZDaemon/ZDaemon.app/Contents/MacOS/ZDaemon
[22:47] <tykje_> 0x64b000 - 0x69105f dyld (551.3) <AEE46C03-FE99-3D3F-9A28-119D4A885857> /usr/lib/dyld
[22:47] <tykje_> 0x9001d000 - 0x901dcff3 com.apple.avfoundation (2.0 - 1535.42) <5D80F90E-349B-3DC6-8EBA-B6D2A10E50C0> /System/Library/Frameworks/AVFoundation.framework/Versions/A/AVFoundation
[22:47] <tykje_> 0x9262d000 - 0x9287bffb com.apple.audio.toolbox.AudioToolbox (1.14 - 1.14) <C0E564FB-7C4D-3893-B03D-5FE49FBE4972> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
[22:47] <tykje_> 0x9287d000 - 0x9287dfff com.apple.audio.units.AudioUnit (1.14 - 1.14) <891EBEA8-EFBC-39E9-A5DC-175390F7B643> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
[22:47] <tykje_> 0xa7280000 - 0xa728fff7 libz.1.dylib (70) <588F445F-0065-3D77-8002-BA9411DA1D70> /usr/lib/libz.1.dylib
[22:47] <tykje_> Model: MacBookPro11,2, BootROM MBP112.0145.B00, 4 processors, Intel Core i7, 2,2 GHz, 16 GB, SMC 2.18f15
[22:47] <tykje_> Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Back to top
View user's profile Send private message
Lyfe
Puts the 'Z' in ZDaemon


Joined: 29 May 2002

PostPosted: Wed Apr 11, 2018 5:39 pm    Post subject: Reply with quote

I think I have it solved as of the last 3 minutes. Please let me know if it works or not.

Anyone who downloaded and has trouble with it before 4:40PM UTC should download it again.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Lyfe
Puts the 'Z' in ZDaemon


Joined: 29 May 2002

PostPosted: Fri May 18, 2018 3:21 pm    Post subject: Reply with quote

Updated release to 1.10.04.

Users of High Sierra will notice that the program mentions that it's not optimized for their systems. The work necessary to optimize ZDaemon for modern MacOS is underway, but it will not be quick.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Lyfe
Puts the 'Z' in ZDaemon


Joined: 29 May 2002

PostPosted: Mon Jul 30, 2018 5:32 pm    Post subject: Reply with quote

Updated release to 1.10.05.

Same note above (1.10.04) applies for High Sierra users.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    ZDaemon Forum Index -> ZDaemon Help & Chatter All times are GMT + 1 Hour
Goto page Previous  1, 2, 3, 4, 5
Page 5 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group