ZDaemon Forum Index ZDaemon
Client/Server DOOM
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Buggy tempo in MIDI playback

 
Post new topic   Reply to topic    ZDaemon Forum Index -> Fixed Bugs
View previous topic :: View next topic  
Author Message
ErisFalling
Posting Spree!


Joined: 29 Jul 2015
Location: GB

PostPosted: Thu Mar 24, 2016 2:08 am    Post subject: Buggy tempo in MIDI playback Reply with quote

It seems some MIDI events are able to cause the tempo on MIDIs to surge so that for a few seconds sound noticeably faster, then return to their original speeds.
I've most recently heard this in MAP20 of DMP15A. Here the tempo surges appear to coincide directly with the choirs (channel 7) using a fade out effect using a ramp of volume change events.

I've heard the same problem with the music on MAP01 of Back to Saturn X E2, though there aren't any such events in this one, though there are a lot of pitch bends. Another example is MAP34 of Slaughterfest 2012, which uses pitch bends very heavily.

I get this with all MIDI devices.
Back to top
View user's profile Send private message
Oxyde
God like!


Joined: 01 Feb 2012
Location: France

PostPosted: Thu Mar 24, 2016 11:42 pm    Post subject: Reply with quote

I get this aswell and confirm this is a ZDaemon since Zandronum, PRBoom and other engines don't suffer from this!
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Krawa
Spamming!


Joined: 23 Nov 2008
Location: #SDA

PostPosted: Sun Apr 29, 2018 2:11 pm    Post subject: Reply with quote

Demo wad with the 3 midis: midi_demo2.wad
Here an image of Alien Jungle (MAP01 of Back to Saturn X E2) to make it visual.
Music example: alien_jungle_zdaemon (you hear the Hi-hat tempo varies) and alien_jungle_zdoom
Back to top
View user's profile Send private message Send e-mail
Krawa
Spamming!


Joined: 23 Nov 2008
Location: #SDA

PostPosted: Wed Dec 05, 2018 10:50 pm    Post subject: Reply with quote

Since 1.10.06 (Music change with ACS lags if switching from/to MIDI) it's not really noticeable any more so it's moved to Fixed Bugs.
image
Back to top
View user's profile Send private message Send e-mail
Flambeau
has entered the game!


Joined: 15 Jun 2017
Location: The Netherlands

PostPosted: Thu Dec 06, 2018 4:52 pm    Post subject: Reply with quote

unexpected side effect Very Happy
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ZDaemon Forum Index -> Fixed Bugs All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group