ZDaemon Forum Index ZDaemon
Client/Server DOOM
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

1.10.01 (2018-03-16) bots go out of sync online

 
Post new topic   Reply to topic    ZDaemon Forum Index -> Confirmed Bugs
View previous topic :: View next topic  
Author Message
Evolution
Spamming!


Joined: 06 Sep 2005

PostPosted: Sat Mar 24, 2018 3:04 am    Post subject: 1.10.01 (2018-03-16) bots go out of sync online Reply with quote

Since 1.10.01 bot movement desyncs particularly when moving between sectors of different heights, as displayed numerous times in the short demo below. Simply, the bot appears to warp position slightly and then will stay in the same position on the server but appear in a different position according to the client. They can thus be seen instantly warping above and below any platforms the client believes them to have collided with. The player can can pass through where he perceives the bot to be, of course.

http://144.76.43.136:10645/demos/20180324_015156_deca2_map01.zdd

More demos (dmc2 map6) can be provided. In those demos, the bot notably gets stuck and begins to warp out of position when attempting to go up or down on the more complex stairs area there. Note the demo provided shows the bot getting stuck on a ledge at the end also.

Bonus:
Back to top
View user's profile Send private message Send e-mail
Evolution
Spamming!


Joined: 06 Sep 2005

PostPosted: Sat Mar 24, 2018 5:37 am    Post subject: Reply with quote

We noted UERR codes issued in a server I launched from zswizard while testing in dmc2 map06

Screenshot: https://drive.google.com/open?id=1i98P8rsNsAzWtmFx8Ahrd235_MY-5g3U

Demo: https://drive.google.com/open?id=1l2geQV-IC8LS_QZC5_7mTL8K3Opkr8UO
Back to top
View user's profile Send private message Send e-mail
Krawa
Spamming!


Joined: 23 Nov 2008
Location: #SDA

PostPosted: Mon Jun 04, 2018 7:00 pm    Post subject: Reply with quote

It's repeatable. It seems the bot has a problem after 23 seconds when he jumps down to green area.

Server demo: 20180604_173052_deca2_map01_server.zdd
Client demo: 2018-06-04_183048_deca2.map01.zdd
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    ZDaemon Forum Index -> Confirmed Bugs All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group