ZDaemon Forum Index ZDaemon
Client/Server DOOM
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TX_START and TX_END texture problems, RESOLVED unhappily

 
Post new topic   Reply to topic    ZDaemon Forum Index -> Wad Editing
View previous topic :: View next topic  
Author Message
Empyre
Spamming!


Joined: 13 Dec 2006
Location: Texas, USA

PostPosted: Thu Aug 04, 2016 2:54 am    Post subject: TX_START and TX_END texture problems, RESOLVED unhappily Reply with quote

I am trying to convert cc4-tex.wad to use the TX_START and TX_END method instead of the older PNAMES and TEXTURES1 method. I used the latest official version of Slade 3 to convert the textures to Doom Graphic paletted. It works flawlessly in ZDoom, GZDoom and Zandronum, but in ZDaemon (and probably Odamex), some custom textures work but some don't. I don't know why. I thought "Maybe ZDaemon doesn't like a texture and doesn't load any after that one.", but I tested that theory, and there is no such pattern. Then I thought "Maybe it is the textures that were originally made of more than 1 patch that don't work.", but I observed that some of the textures that do work were indeed made from more than 1 patch before conversion. There seems to be no rhyme or reason behind which ones work and which ones don't.

Here is the texture pack I "made": cc4-tex2_b1.zip, and a test wad to show the problem: cc4-tex-test_v1.zip, and the original texture pack in case you don't already have it: cc4.tex.zip. The test wad shows the first 256 flats (no problems there) and the first 258 textures (plus a few more because of animated textures).

The original works fine, but it steps on the toes of other wads that also load textures that way. I would like to be able to load my maps wad with other maps, and still have it work in ZDaemon.

Can somebody please help me figure out the problem?


Last edited by Empyre on Sun Aug 07, 2016 9:59 am; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail
Empyre
Spamming!


Joined: 13 Dec 2006
Location: Texas, USA

PostPosted: Sun Aug 07, 2016 9:57 am    Post subject: Reply with quote

Never-mind. I hadn't cleared my maps wad from loading, so the textures that were working were the ones in my wad.

This isn't what I wanted the answer to be, but now that I know, I'll just abandon the idea loading my maps with other maps. I think I have enough of them now to do that. With that in mind, I can rename them from EMPxx back to MAPxx. I think I'll still use non-standard song names, like D_MAPxx. to make it easier to figure out what song goes with which map.
Back to top
View user's profile Send private message Send e-mail
Aeyesx
Spamming!


Joined: 13 Oct 2012
Location: Czech Republic

PostPosted: Fri Aug 12, 2016 10:55 am    Post subject: Reply with quote

Don't use TX_* i guess. Bad idea in first place, does zdaemon even support that? Partially maybie, I would avoid it, its an dead-end.
Back to top
View user's profile Send private message Send e-mail
Sr69Mm-jC
Spamming!


Joined: 21 Jul 2011

PostPosted: Fri Aug 12, 2016 11:05 am    Post subject: Reply with quote

Aeyesx wrote:
Don't use TX_* i guess.

I'd rather say don't use EMPxx for map names. There's little to no reason to deviate from the standard MAPxx convention.

Empyre wrote:
This isn't what I wanted the answer to be, but now that I know, I'll just abandon the idea loading my maps with other maps. I think I have enough of them now to do that.

I honestly don't know why you did that in the first place. Even if your mod is relatively short, it's still definitely okay to host it as is. Why would you mix it with other maps/mods and also break the MAPxx convention?

I admit I didn't read too deeply in the explanation of the problem itself, and I understand it might be a ZDaemon limitation or something, but I just wanted to say that you probably shouldn't be unhappy about resolving the problem in such a way; it sounds likes a decent fix on your end to me.
Back to top
View user's profile Send private message
Aeyesx
Spamming!


Joined: 13 Oct 2012
Location: Czech Republic

PostPosted: Fri Aug 12, 2016 2:37 pm    Post subject: Reply with quote

How is map name related to textures? Shocked
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    ZDaemon Forum Index -> Wad Editing All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group