ZDaemon Forum Index ZDaemon
Client/Server DOOM
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Server 1.10 Beta 09 - FreeBSD

 
Post new topic   Reply to topic    ZDaemon Forum Index -> General Offtopic Chat
View previous topic :: View next topic  
Author Message
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Tue Aug 04, 2015 10:57 am    Post subject: Server 1.10 Beta 09 - FreeBSD Reply with quote

any chance to get freebsd version of zserv 1.10 B04 ??

Last edited by cyberreality on Mon Feb 12, 2018 5:41 pm; edited 3 times in total
Back to top
View user's profile Send private message
Lyfe
Puts the 'Z' in ZDaemon


Joined: 29 May 2002

PostPosted: Tue Aug 04, 2015 9:09 pm    Post subject: Reply with quote

I thought Kilgore usually did FreeBSD server builds too, but here's one. YMMV in terms of me forgetting anything, since I haven't checked it too thoroughly. (Just sort of built it, and made sure it ran.)

This was built on FreeBSD 10. So if you're on 9.4, the latest 8.x branch, or 11-current, I'm not sure it'll work right.

http://www.gameowls.com/zserv-1.10b4.tar.gz
Back to top
View user's profile Send private message Send e-mail Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Tue Aug 04, 2015 9:20 pm    Post subject: Reply with quote

thanks! i'm back online, i'm on 10-stable
Back to top
View user's profile Send private message
Kilgore
Air Cavalry


Joined: 17 Jun 2003
Location: Up the river

PostPosted: Wed Aug 05, 2015 11:39 am    Post subject: Reply with quote

I hadn't seen Lyfe's post, but.... if you have trouble, try this one. And if you still have trouble, let me know and I will see what can be done about it.
Back to top
View user's profile Send private message Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Wed Aug 05, 2015 1:37 pm    Post subject: Reply with quote

no problems so far, it seems like lyfe's build works well, so i case of any problem i'd try your build, thanks
Back to top
View user's profile Send private message
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Mon Sep 04, 2017 5:50 pm    Post subject: Reply with quote

well, freebsd binary of latest beta08? :)
thanks
Back to top
View user's profile Send private message
Kilgore
Air Cavalry


Joined: 17 Jun 2003
Location: Up the river

PostPosted: Wed Sep 06, 2017 7:42 am    Post subject: Reply with quote

Lyfe made a freebsd 10.x binary. See if that helps.
Back to top
View user's profile Send private message Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Wed Sep 06, 2017 8:50 pm    Post subject: Reply with quote

not working ...

beta07:

/data/doom/zdaemon% ./zserv
OS: FreeBSD 10.4-BETA2
Can't find 'zdaemon.wad'
Cannot find zdaemon.wad

i have all WADs in separate folder so the error is OK


beta08:

/data/doom/zdaemon% ./zserv
./zserv: 2: not found
./zserv: 0: not found
./zserv: 1835008: not found
./zserv: 2097152: not found
./zserv: 3166556: not found
./zserv: 6: Syntax error: "(" unexpected

i put zdaemon.wad into same folder, still the same ...
Back to top
View user's profile Send private message
Lyfe
Puts the 'Z' in ZDaemon


Joined: 29 May 2002

PostPosted: Wed Sep 06, 2017 11:21 pm    Post subject: Reply with quote

I just fired up a fresh install of FreeBSD 10.4-beta3, extracted the tgz that Kilgore posted, copied my doom2.wad, and ran "./zserv" and it fired up just fine.

I meant to try 10.4-beta2, but I apparently downloaded beta3.

Quote:
lyfe@test104 ~/zserv110_bin > ./zserv
OS: FreeBSD 10.4-BETA3
adding zdaemon.wad (515 lumps)
adding doom2.wad (2919 lumps)
Init DOOM refresh subsystem.
Init Playloop state.
Starting network and creating sockets
IP address 0.0.0.0:10666
UDP Initialized
1. map01


Based on the error you're getting, can you look at your zserv.cfg and see if there's something weird going on there? Can you also check that you don't have any aliases defined which might be intercepting "./zserv" and trying to execute something else?
Back to top
View user's profile Send private message Send e-mail Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Thu Sep 07, 2017 6:01 pm    Post subject: Reply with quote

now with doom2.wad ... 07 first then 08 ...


/data/doom/zdaemon/test% ls
doom2.wad zdaemon.wad zserv

/data/doom/zdaemon/test% ./zserv
OS: FreeBSD 10.4-BETA2
adding zdaemon.wad (515 lumps)
adding doom2.wad (2919 lumps)
Init DOOM refresh subsystem.
Init Playloop state.
Starting network and creating sockets
IP address 188.95.56.9:10666
UDP Initialized
Couldn't load configuration file (zserv.cfg).
/data/doom/zdaemon/test%

/data/doom/zdaemon/test% ./zserv
./zserv: 2: not found
./zserv: 0: not found
./zserv: 1835008: not found
./zserv: 2097152: not found
./zserv: 3166556: not found
./zserv: 6: Syntax error: "(" unexpected
/data/doom/zdaemon/test%
Back to top
View user's profile Send private message
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Thu Sep 07, 2017 6:09 pm    Post subject: Reply with quote

seems to be problem with binary itself, not looking like a beginning of normal binary ... so plz would be possible to compile once more time?

/data/doom/zdaemon/test/zserv 5804/4885K 0%
2
0
1835008
2097152
3166556
...............................................................................................................................................................
...............................................................................................................................................................
...............................................................................................................................................................
........ELF...
Back to top
View user's profile Send private message
Lyfe
Puts the 'Z' in ZDaemon


Joined: 29 May 2002

PostPosted: Fri Sep 08, 2017 4:37 am    Post subject: Reply with quote

Try this one. Built it on the FreeBSD 10.4-beta3 system I installed the other day.

http://zdaemon.info/files/zserv110_freebsd10_4.tgz

If it works, I'll have Kilgore post that on the main site (and replace the other one).
Back to top
View user's profile Send private message Send e-mail Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Fri Sep 08, 2017 5:27 am    Post subject: Reply with quote

WORKS !! thanks
Back to top
View user's profile Send private message
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Mon Feb 12, 2018 5:40 pm    Post subject: Reply with quote

it's nice to have new version of zserv right on my birthday, but would be possible to have freebsd version of zserv as well?? :))

thanks
Back to top
View user's profile Send private message
AF-Domains.net
Dark Messenger of IRC


Joined: 01 Jun 2002
Location: United Kingdom

PostPosted: Wed Feb 14, 2018 10:38 am    Post subject: Reply with quote

A bit of fun was encountered, this is being looked into though.

Edit: FreeBSD build is ready:
-- Link Removed --


Last edited by AF-Domains.net on Wed Feb 14, 2018 2:32 pm; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Wed Feb 14, 2018 12:48 pm    Post subject: Reply with quote

works well, thanks, BUT it shows:

./zserv -version
1.10b08

the same zdaemon client ...
Back to top
View user's profile Send private message
AF-Domains.net
Dark Messenger of IRC


Joined: 01 Jun 2002
Location: United Kingdom

PostPosted: Wed Feb 14, 2018 12:50 pm    Post subject: Reply with quote

When you extracted the archive, did it create any additional directories?
Back to top
View user's profile Send private message Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Wed Feb 14, 2018 2:26 pm    Post subject: Reply with quote

nope, just replaced original files ...

./zserv -version
1.10b08
date -r zserv
Wed Feb 14 04:48:39 CET 2018


Last edited by cyberreality on Wed Feb 14, 2018 2:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
AF-Domains.net
Dark Messenger of IRC


Joined: 01 Jun 2002
Location: United Kingdom

PostPosted: Wed Feb 14, 2018 2:26 pm    Post subject: Reply with quote

In that case, I've sent you a PM on IRC.
Back to top
View user's profile Send private message Visit poster's website
cyberreality
has entered the game!


Joined: 03 Sep 2005
Location: knee-deep in the dead

PostPosted: Wed Feb 14, 2018 2:28 pm    Post subject: Reply with quote

AF-Domains.net wrote:
In that case, I've sent you a PM on IRC.


well, currently in work :) let me connect to home computer :)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ZDaemon Forum Index -> General Offtopic Chat All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group